سنوضح لك كيفية تعديل ملفات XLIFF التي ينتجها WPML في OmegaT.
1. إنشاء مشروع جديد وفتحه
اختر Project → New... من القائمة.
انتقل إلى المجلد الذي ترغب في حفظ ملفات المشروع فيه، واكتب اسماً لمشروع الترجمة. سيُستخدم هذا الاسم لمجلد المشروع الرئيسي؛ وستُخزن جميع ملفات المشروع في هذا المجلد أو في مجلداته الفرعية.
سيطالبك OmegaT بتأكيد أو تغيير مجلدات المشروع التي سيتم إنشاؤها، باستخدام مربع الحوار أدناه:

اختر رمز اللغة (حرفان) أو رمز اللغة والمنطقة (حرفان + حرفان) من القائمة المنسدلة، أو اكتبها يدوياً.
إذا كنت تريد أن يقوم OmegaT بتقسيم ملفك بطريقة معينة، فتحقق من Segmentation Rules أو قم بذلك لاحقاً من القائمة: Options → Segmentation
عندما تنقر على OK لقبول إعداد المشروع، سيطالبك OmegaT بتحديد المستندات المصدر لاستيرادها. يمكنك استيراد ملفات فردية، أو يمكنك استيراد شجرات مجلدات كاملة (بجميع الملفات الموجودة في جميع المجلدات الفرعية).
للتحقق من قائمة الملفات المراد ترجمتها، راجع نافذة Project Files (القائمة: Project → Project Files...، إذا لم تُفتح تلقائياً). إذا اضطررت إلى تغيير محتويات المجلد المصدر، فتذكر إعادة تحميل المشروع أولاً (القائمة: Project → Reload). يفتح OmegaT الملف الأول في قائمة المشروع افتراضياً.
لا يمكن لـ OmegaT ترجمة الملفات إلا بالتنسيقات أدناه إذا كانت تتطابق مع الأنماط المحددة في عوامل تصفية الملفات. سيتم تجاهل أي ملفات أخرى.
- OpenDocument/OpenOffice.org
- نص عادي (Plain text)
- .po
- Bundle.properties Java
- XHTML, HTML
- HTML Help Compiler
- INI (تنسيق 'key=value')
- DocBook
- Microsoft Open XML
- Okapi monolingual XLIFF
- QuarkXPress CopyFlowGold
- Subtitle files (SRT)
- ResX
- Android resource
- LaTeX
2. كيفية استيراد ملفات XLIFF
ما يبدو أنه يلفت الانتباه من الملفات المدرجة أعلاه هي ملفات XLIFF. عندما تحاول استيراد ملف بتنسيق *.xliff، ستفاجأ بأن الملف غير معترف به. يمكن حل هذه المشكلة بسهولة عن طريق التحقق في عوامل تصفية الملفات (القائمة: Options → File Filters) مما إذا كان نمط اسم الملف المصدر لملفات XLIFF يتضمن الامتداد *.xliff.

لسوء الحظ، تتضمن الإعدادات الافتراضية لـ OmegaT الامتداد *.xlf فقط، لذلك يجب عليك إضافة الامتداد *.xliff بنفسك عن طريق النقر على الصف الذي يحتوي على ملفات XLIFF ثم Edit. سيتعين عليك ببساطة النقر على Add لإضافة صف مطابق للصف الموجود، ولكن مع تغيير نمط اسم الملف المصدر إلى النمط الذي تريد استخدامه.

بعد الانتهاء من هذه العمليات، سيتم استيراد الملف بنجاح إلى مشروعك.
3. تقسيم المصدر
يحتوي OmegaT على طريقتين لتقسيم النص: تقسيم الفقرات وتقسيم الجمل. لتحديد نوع التقسيم، اختر Project → Properties... من القائمة الرئيسية واستخدم مربع الاختيار المتاح.

لاحظ أن تقسيم الفقرات يعتبر قديماً إلى حد كبير، وأن تقسيم الجمل هو الخيار المفضل لغالبية المشاريع. إذا تم تحديد تقسيم الجمل، فيمكنك إعداد القواعد باختيار Options → Segmentation... من القائمة الرئيسية.
يحلل OmegaT النص أولاً لتقسيمه على مستوى البنية. خلال هذه العملية، تُستخدم بنية الملف المصدر فقط لإنتاج المقاطع.
على سبيل المثال، قد يتم تقسيم الملفات النصية عند فواصل الأسطر، أو الأسطر الفارغة، أو قد لا يتم تقسيمها على الإطلاق. يتم تقسيم الملفات ذات التنسيق (مستندات OpenOffice.org، ومستندات HTML/XLIFF، وما إلى ذلك) بناءً على وسوم مستوى الكتلة (الفقرة).
بعد تقسيم الملف المصدر إلى وحدات منطقية، سيقوم OmegaT بتقسيم هذه الكتل بشكل إضافي إلى جمل.
هناك نوعان من قواعد التقسيم:
• قواعد الفاصل (Break rules) تفصل النص المصدر إلى مقاطع. على سبيل المثال، يجب فصل «Did it make sense? I was not sure.» (هل كان ذلك منطقياً؟ لم أكن متأكداً.) إلى مقطعين، مما يعني أنه يجب أن تكون هناك قاعدة فاصل للعلامة «?».

• قواعد الاستثناء (Exception rules) تحدد أجزاء النص التي يجب ألا يتم فصلها. على الرغم من وجود النقطة، يجب ألا يتم فصل «Mrs. Dalloway» إلى مقطعين، لذلك يجب إنشاء قاعدة استثناء لكلمة Mrs (و Mr و Dr و prof وما إلى ذلك)، متبوعة بنقطة.
4. إنشاء القواعد
لتعديل مجموعة قواعد موجودة أو توسيعها، ما عليك سوى النقر عليها في الجدول العلوي. ستظهر قواعد المجموعة في النصف السفلي من النافذة.

لإنشاء مجموعة قواعد فارغة لنمط لغة/نوع ملف جديد، انقر على Add في النصف العلوي من مربع الحوار. سيظهر سطر فارغ في أسفل الجدول العلوي (قد تضطر إلى التمرير لأسفل لرؤيته). قم بتغيير اسم مجموعة القواعد ونمط اللغة. تتوافق بنية نمط اللغة مع بنية التعبيرات النمطية. إذا كانت مجموعة قواعدك تتعامل مع زوج لغوي وبلد، فننصحك بنقلها إلى الأعلى باستخدام زر Move Up .

يحدد مربع الاختيار Break/Exception ما إذا كانت قاعدة فاصل (مربع الاختيار محدد) أو قاعدة استثناء (مربع الاختيار غير محدد). يحدد تعبيران نمطيان Before و After ما يجب أن يكون قبل وبعد موضع معين حتى يكون مؤهلاً لقاعدة استثناء أو قاعدة فاصل.
5. إنشاء قواعد التقسيم لملفات XLIFF
عند التعامل مع ملفات XLIFF، سنرغب فوراً في تحديد قاعدة تقسيم، وإلا سيبدو المستند المراد ترجمته مشابهاً لما يلي:

بالنسبة لأي ملف يحتوي على تنسيق، ستلاحظ أن التقسيم يكون عند وسم مستوى الفقرة، وهو ما لا يبدو منظماً جداً لملفات XLIFF، لذلك ستحتاج على الأرجح إلى استخراج المحتوى القابل للترجمة إلى مقاطع مختلفة. في الختام، تحتاج إلى إنشاء قاعدة تقسيم.
على الرغم من أن ملفات XLIFF قياسية، إلا أنها تحتوي على بعض العناصر الفريدة في WordPress. عادةً، في HTML، تقوم بإدراج وسوم <br /> لإنشاء فواصل أسطر. في WordPress، تُنشئ الأسطر الجديدة فواصل أسطر أيضاً. يتم الآن استبدال الأسطر الجديدة بوسم: <br class="xliff-newline"/>.
يمكنك بسهولة إنشاء قاعدة لهذا النوع من الملفات باتباع الخطوات الواردة في قسم «إنشاء القواعد» واستخدام هذا الوسم كنمط بعد التقسيم وأي حرف (باستثناء نهايات الأسطر) للنمط قبل التقسيم (حيث «.» هي فئة أحرف محددة مسبقاً).
أنشئ القاعدة كما في:

بعد تطبيق القاعدة، سيتم تنظيم الوسوم غير الملائمة في مقاطع منفصلة، في حالة وجود سطر فارغ، أو قبل الجملة، حيث يحتوي السطر على معلومات. وبالتالي، سيكون المحتوى القابل للترجمة أكثر وضوحاً من ذي قبل.

6. إنشاء مستندات مترجمة
عندما تنتهي من ترجمة جميع المقاطع (أو قبل ذلك إذا أردت)، سيقوم OmegaT بتحديث المستند (المستندات) الهدف باستخدام الترجمات المخزنة في ذاكرة الترجمة. للقيام بذلك، اختر Project → Create Translated Documents من القائمة. سيقوم OmegaT ببناء نسخ مترجمة من جميع المستندات القابلة للترجمة في مجلد المصدر الخاص بالمشروع، سواء تمت ترجمتها بالكامل أم لا. سيتم حفظ الملفات المترجمة كلياً أو جزئياً في المجلد الهدف الخاص بالمشروع بنفس الاسم ونفس امتداد المستند المصدر. لإنهاء ترجمتك، افتح الملفات الهدف في تطبيقاتها المرتبطة (المتصفح، معالج النصوص...) للتحقق من محتوى وتنسيق ترجمتك. يمكنك بعد ذلك العودة إلى OmegaT لإجراء أي تصحيحات ضرورية؛ ولا تنسَ إعادة إنشاء المستندات المترجمة.
في لقطات الشاشة أعلاه، يمكنك رؤية دليل المشروع بالكامل.
لنفترض أنك انتهيت للتو من ترجمة ملف XLIFF وتريد رفعه إلى WPML. للقيام بذلك، كل ما تحتاجه هو العثور على الملف المترجم في المجلد الهدف ورفعه من ذلك الموقع.

يمكنك أيضاً عمل نسخة منه وحفظها في موقع آخر. سيتم إجراء أي تعديل يتعلق بتنسيق الترجمة في WPML، ويمكن إجراء تصحيحات على ترجمتك إما في WPML أو في OmegaT.
