Chúng tôi sẽ hướng dẫn bạn cách chỉnh sửa các tệp XLIFF do WPML tạo ra trong OmegaT.
1. Tạo và mở một dự án mới
Chọn Project → New… từ menu.
Điều hướng đến thư mục mà bạn muốn lưu các tệp dự án và nhập tên cho dự án dịch. Tên này sẽ được sử dụng cho thư mục dự án chính; tất cả các tệp dự án sẽ được lưu trữ trong thư mục này hoặc các thư mục con của nó.
OmegaT sẽ yêu cầu bạn xác nhận hoặc thay đổi các thư mục dự án sẽ được tạo, sử dụng hộp thoại bên dưới:

Chọn mã ngôn ngữ (2 chữ cái) hoặc mã ngôn ngữ và khu vực (2 + 2 chữ cái) từ danh sách thả xuống, hoặc nhập thủ công.
Nếu bạn muốn OmegaT phân đoạn tệp của mình theo một cách cụ thể, hãy chọn Segmentation Rules (Quy tắc phân đoạn) hoặc thực hiện việc đó sau từ menu: Options → Segmentation
Khi bạn nhấp vào OK để chấp nhận thiết lập dự án, OmegaT sẽ yêu cầu bạn chọn các tài liệu nguồn để nhập. Bạn có thể nhập từng tệp riêng lẻ hoặc nhập toàn bộ cây thư mục (với tất cả các tệp trong tất cả các thư mục con).
Để kiểm tra danh sách các tệp cần dịch của bạn, hãy xem cửa sổ Project Files (Menu: Project → Project Files…, nếu nó không tự động mở). Nếu bạn phải thay đổi nội dung của thư mục Source (Nguồn), hãy nhớ tải lại dự án trước (Menu: Project → Reload). OmegaT mở tệp đầu tiên trong danh sách dự án theo mặc định.
OmegaT chỉ có thể dịch các tệp ở các định dạng bên dưới nếu chúng khớp với các mẫu được xác định trong bộ lọc tệp (file filters). Bất kỳ tệp nào khác sẽ bị bỏ qua.
- OpenDocument/OpenOffice.org
- Văn bản thuần túy
- .po
- Bundle.properties Java
- XHTML, HTML
- HTML Help Compiler
- INI (định dạng 'key=value')
- DocBook
- Microsoft Open XML
- Okapi monolingual XLIFF
- QuarkXPress CopyFlowGold
- Tệp phụ đề (SRT)
- ResX
- Tài nguyên Android
- LaTeX
2. Cách nhập tệp XLIFF
Điều dường như thu hút sự chú ý từ các tệp được liệt kê ở trên là các tệp XLIFF. Khi bạn cố gắng nhập một tệp ở định dạng *.xliff, bạn sẽ ngạc nhiên khi thấy tệp không được nhận dạng. Vấn đề này có thể được giải quyết dễ dàng bằng cách kiểm tra trong các bộ lọc tệp (Menu: Options → File Filters) xem mẫu tên tệp nguồn cho các tệp XLIFF có bao gồm phần mở rộng *.xliff hay không.

Rất tiếc, các cài đặt mặc định của OmegaT chỉ bao gồm phần mở rộng *.xlf, do đó bạn phải tự thêm phần mở rộng *.xliff bằng cách nhấp vào hàng chứa tệp XLIFF và sau đó nhấp vào Edit. Bạn sẽ chỉ cần Add một hàng giống hệt hàng hiện có, chỉ thay đổi mẫu tên tệp nguồn thành mẫu bạn muốn sử dụng.

Sau khi bạn hoàn thành các thao tác này, tệp sẽ được nhập thành công vào dự án của bạn.
3. Phân đoạn nguồn
OmegaT có 2 cách để phân đoạn văn bản: phân đoạn theo đoạn văn và phân đoạn theo câu. Để chọn loại phân đoạn, hãy chọn Project → Properties… từ menu chính và sử dụng hộp kiểm có sẵn.

Lưu ý rằng phân đoạn theo đoạn văn đã khá lỗi thời và đối với phần lớn các dự án, phân đoạn theo câu là lựa chọn được ưu tiên. Nếu phân đoạn theo câu đã được chọn, bạn có thể thiết lập các quy tắc bằng cách chọn Options → Segmentation… từ menu chính.
Đầu tiên, OmegaT phân tích cú pháp văn bản để phân đoạn ở cấp độ cấu trúc. Trong quá trình này, chỉ có cấu trúc của tệp nguồn được sử dụng để tạo ra các phân đoạn.
Ví dụ: các tệp văn bản có thể được phân đoạn dựa trên ngắt dòng, dòng trống hoặc hoàn toàn không được phân đoạn. Các tệp có định dạng (tài liệu OpenOffice.org, tài liệu HTML/XLIFF, v.v.) được phân đoạn dựa trên các thẻ cấp độ khối (đoạn văn).
Sau khi phân đoạn tệp nguồn thành các đơn vị logic, OmegaT sẽ tiếp tục phân đoạn các khối này thành các câu.
Có hai loại quy tắc phân đoạn:
• Break rules (Quy tắc ngắt) tách văn bản nguồn thành các phân đoạn. Ví dụ: “Did it make sense? I was not sure.” (Điều đó có ý nghĩa không? Tôi không chắc chắn.) nên được tách thành hai phân đoạn, nghĩa là cần có một quy tắc ngắt cho dấu “?”.

• Exception rules (Quy tắc ngoại lệ) chỉ định những phần văn bản nào KHÔNG nên bị tách ra. Bất chấp dấu chấm, “Mrs. Dalloway ” không nên bị tách thành hai phân đoạn, vì vậy cần thiết lập một quy tắc ngoại lệ cho Mrs (và Mr, Dr, prof, v.v.), theo sau là dấu chấm.
4. Tạo quy tắc
Để chỉnh sửa hoặc mở rộng một bộ quy tắc hiện có, bạn chỉ cần nhấp vào nó trong bảng trên cùng. Các quy tắc của bộ này sẽ xuất hiện ở nửa dưới của cửa sổ.

Để tạo một bộ quy tắc trống cho một mẫu ngôn ngữ/loại tệp mới, hãy nhấp vào Add ở nửa trên của hộp thoại. Một dòng trống sẽ xuất hiện ở cuối bảng trên (bạn có thể phải cuộn xuống để xem). Thay đổi tên của bộ quy tắc và mẫu ngôn ngữ. Cú pháp của mẫu ngôn ngữ tuân theo cú pháp biểu thức chính quy. Nếu bộ quy tắc của bạn xử lý một cặp ngôn ngữ-quốc gia, chúng tôi khuyên bạn nên di chuyển nó lên trên cùng bằng nút Move Up.

Hộp kiểm Break/Exception xác định xem đó là quy tắc ngắt (chọn hộp kiểm) hay quy tắc ngoại lệ (bỏ chọn hộp kiểm). Hai biểu thức chính quy Before và After chỉ định những gì phải có trước và sau một vị trí nào đó để nó đủ điều kiện cho quy tắc ngoại lệ hoặc quy tắc ngắt.
5. Tạo quy tắc phân đoạn cho tệp XLIFF
Khi xử lý các tệp XLIFF, chúng ta sẽ muốn xác định ngay một quy tắc phân đoạn, nếu không tài liệu cần dịch sẽ trông giống như thế này:

Đối với bất kỳ tệp nào có định dạng, bạn sẽ nhận thấy rằng việc phân đoạn nằm ở thẻ cấp độ đoạn văn, điều này đối với các tệp XLIFF trông không được tổ chức tốt cho lắm, vì vậy bạn có thể sẽ muốn trích xuất nội dung có thể dịch thành các phân đoạn khác nhau. Tóm lại, bạn cần tạo một quy tắc phân đoạn.
Mặc dù các tệp XLIFF là tiêu chuẩn, chúng chứa một số phần tử dành riêng cho WordPress. Thông thường, trong HTML, bạn chèn các thẻ <br /> để tạo ngắt dòng. Trong WordPress, các dòng mới cũng tạo ra ngắt dòng. Các dòng mới hiện được thay thế bằng một thẻ: <br class="xliff-newline"/>.
Bạn có thể dễ dàng tạo một quy tắc cho loại tệp này bằng cách làm theo các bước trong phần "Tạo quy tắc" và sử dụng thẻ này làm mẫu sau khi phân đoạn và bất kỳ ký tự nào (ngoại trừ các ký tự kết thúc dòng) cho mẫu trước khi phân đoạn (trong đó "." là một lớp ký tự được xác định trước).
Tạo quy tắc như trong hình:

Sau khi áp dụng quy tắc, các thẻ bất tiện sẽ được tổ chức thành các phân đoạn riêng biệt, trong trường hợp có dòng trống, hoặc trước câu, nơi dòng chứa thông tin. Do đó, nội dung có thể dịch sẽ dễ nhận thấy hơn so với trước đây.

6. Tạo các tài liệu đã dịch
Khi bạn đã dịch tất cả các phân đoạn (hoặc sớm hơn nếu bạn muốn), OmegaT sẽ cập nhật (các) tài liệu đích bằng cách sử dụng các bản dịch được lưu trữ trong bộ nhớ dịch. Để thực hiện việc này, hãy chọn Project → Create Translated Documents từ menu. OmegaT sẽ xây dựng các phiên bản đã dịch của tất cả các tài liệu có thể dịch trong thư mục Source của dự án, bất kể chúng đã được dịch hoàn toàn hay chưa. Các tệp được dịch toàn bộ hoặc một phần sẽ được lưu vào thư mục Target của dự án với cùng tên và cùng phần mở rộng như tài liệu nguồn. Để hoàn thiện bản dịch của bạn, hãy mở các tệp đích trong các ứng dụng liên kết của chúng (trình duyệt, trình xử lý văn bản…) để kiểm tra nội dung và định dạng của bản dịch. Sau đó, bạn có thể quay lại OmegaT để thực hiện bất kỳ sửa chữa cần thiết nào; đừng quên tạo lại các tài liệu đã dịch.
Trong các ảnh chụp màn hình ở trên, bạn có thể thấy toàn bộ thư mục của dự án.
Giả sử bạn vừa dịch xong một tệp XLIFF và bạn muốn tải nó lên WPML. Để thực hiện việc này, bạn chỉ cần tìm tệp đã dịch trong thư mục Target và tải nó lên từ vị trí đó.

Bạn cũng có thể tạo một bản sao của nó và lưu vào một vị trí khác. Bất kỳ sửa đổi nào liên quan đến định dạng của bản dịch sẽ được thực hiện trong WPML và các sửa chữa cho bản dịch của bạn có thể được thực hiện trong WPML hoặc trong OmegaT.
